PowerShell Module

PowerShell Module for the SharePoint Patch Service

Get the PowerShell module to interact with the Patch API. The module contains four cmdlets:

When installing the PowerShell module, select the appropriate version of SharePoint if installing it on a SharePoint server. Only Install-SPPatch requires SharePoint to be installed locally.

The module supports a minimum of PowerShell 2.0/.NET 2.0. If running PowerShell 2.0 (e.g. when used with SharePoint 2010), you must first run Import-Module SharePointPatches in order to access the cmdlets. Higher version of PowerShell will autodetect the module.

Download